Emails are delayed

Incident Report for Eventive

Resolved

This incident has been resolved. All email functionality has returned to normal.
Posted Nov 04, 2025 - 13:44 CST

Investigating

We are currently experienced delays with the sending of emails and mailings. All other functionality is working fine. We will update as we have further information
Posted Nov 04, 2025 - 10:30 CST
This incident affected: Virtual platform, Event websites, Payment processing, and Organizer admin panel.